Account Funding and Withdrawals
Incident Report for Nadex
Resolved
This incident has been resolved.
Posted Nov 05, 2019 - 17:58 CST
Investigating
We are experiencing a technical issue causing intermittent availability for account funding and withdrawals. Our team is working towards a resolution and will provide a status update as soon as possible. We apologize for any inconvenience. Thank you for your patience. Please check this page for further updates.
Posted Nov 05, 2019 - 12:24 CST
This incident affected: Payments.