Technical Issue
Incident Report for Nadex
Resolved
This incident has been resolved.
Posted Nov 06, 2023 - 10:59 CST
Investigating
We are experiencing a technical issue and apologize for any inconvenience. Our team is working towards a resolution and will provide a status update as soon as possible. Thank you for your patience. Please check this page for further updates.
Posted Nov 06, 2023 - 07:54 CST
This incident affected: Trading Platform (Live Web Trading Platform) and Mobile Apps.